Decoder an MP1-Antrieb

  • Hallo Digitalprofis,


    bevor ich mir den Decoder schrotte, frage ich hier doch mal als Laie.


    Ich habe mir einen Decoder 40802 von Decoderwerk gekauft, der motorische Antriebe schalten kann.

    Er besitzt, im Gegensatz zu anderen Decodern, nur die Schaltausgänge links/rechts, also zwei Anschlüsse pro Ausgang.

    Dann müsste ich logischerweise den mittleren Ausgang (Com +) ja direkt an den Trafo anklemmen, oder zerschieße

    ich mir den Decoder?

    Ja, der Hersteller hat auch keine Ahnung. Er kennt den Antrieb nicht. Frage ich jetzt bei MTB an, kennen die den

    Decoder nicht?


    40802 Weichendecoder zur Steuerung von 8 Weichen mit Motorantrieben - DECODERWERK
    Der Decoder verfügt über 8 Ausgänge. Der Betrieb kann mit DCC oder Märklin Motorola erfolgen. Der Decoder eignet sich für Weichen mit Motorantrieb oder für…
    www.decoderwerk.com

    MTB-model.com

  • Hallo nozet,


    Gut, dass Du vor dem Anschluss fragst, denn laut Datenblatt (=Bedienungsanleitung) polt der Decoder die beiden Anschlüsse einer Weiche. Damit funktionieren die von Dir vorgesehenen Weichenantriebe nicht. Eine Schaltung Deiner Antriebe mit dem Decoder funktioniert also nicht!


    Freundlicher Gruß

    EsPe

  • Hallo Norbert,


    bei deinem Decoder wird der Antrieb geschalten indem die Polung bei dem jeweiligen Anschlußpaar geändert wird. Bei einer Richtung ist z.B. der linke Anschluß plus und der rechte Anschluß Minus. Beim Umschalten dann der linke Anschluß Minus und der rechte Anschluß plus.


    Der MP1 braucht aber einen Decoder der den jeweiligen Anschluß gegen Masse schaltet, also Com+ an dem immer plus anliegt und je nachdem in welche Richtung geschalten werden soll, wird einer der anderen beiden Anschlüsse auf Masse geschalten.

  • Verstehen tue ich das zwar nicht, aber ich lasse mal die Finger davon.

    Ich habe es so verstanden, dass der Decoder entweder einen Impuls an den

    einen, oder anderen Ausgang abgibt.

    Nein, leider nicht. Dein Decoder polt nur die beiden Kontakte um, so wie Benderfhd das beschrieben hat.


    Freundlicher Gruß

    EsPe

  • Hallole,

    so ganz stimmt das nicht...

    Man kann 2 Dioden (z.B.: 1N4001) nehmen und die fehlende +Spannung erzeugen...

    z.B.:

    1. Anoden der beiden Dioden an die beiden Ausgänge anschliessen, Kathoden verbinden = + Ausgang >> verbinden mit dem +Eingang des Antriebs

    2. die beiden Steueingänge des Antriebs mit den Ausgängen des Decoders verbinden...

    und schon funktionierts....

    MfG

    M. K.

  • Hallo Norbert,

    das hört sich doch gut an, dann war der Decoder ja doch nicht ganz falsch.

    Und mit der Z21 wird es auch funktionieren, das kriegst du auch hin.


    Fröhliches basteln wünscht

    Meinhard,
    der wohl immer noch nördlichste Nuller Deutschlands

  • Hallo,


    3 Stück umgebaut und eingebaut....dann fingen die Probleme an.

    Teilweise schalteten die Antriebe gar nicht, teilweise nur in eine Richtung, oder hin und her.


    Zur besseren Verdeutlichung habe ich ein kurzes Video erstellt.


    Liegt es an den Dioden? Am Zusammenspiel zwischen Decoder - z21 - Dioden?

    Oder sind eventuell andere Dioden nötig?


    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • Hallole,

    Das sieht nach einem Decoderproblem aus.

    Standard ist ein Ausgangs Impuls von 4s eingestellt....!!!

    Keine Ahnung was passiert wenn du in kürzeren Abständen die Weiche schaltest....

    Schalte doch einmal mit 10s Abstand...

    MfG

    M. K.

  • Moin


    Schaltzeiten lassen sich bei der z21 zwischen 100 - 500 Millisekunden einstellen.

    Anscheinend interessiert das weder den Decoder, noch die z21-App.

    100, 400, 500 ausprobiert, keine Veränderung festzustellen.

    Durch einen klemmenden Antrieb habe ich herausgefunden, dass der Decoder

    nach wie vor 4 Sekunden ausgibt.

    Leider sehe ich keine Möglichkeit mit dem System die Zubehör-CVs direkt

    zu programmieren. Ich frage mal bei Decoderwerk nach, warum der Decoder

    immer 4 Sekunden ausgibt.

    Schalten tut er alle MP1, aber mit unterschiedlichen Ansprechzeiten und Pausen

    zwischendurch.

  • Moin,

    Ich denke, die sehr kurzen Schaltzeiten der z21sind eher für Magnetspulenantriebe gedacht, für einen motorischen Antrieb sind die 4 Sekunden des Decoders schon richtig und lassen sich demzufolge wohl auch nicht ändern, egal was an der z21 eingestellt ist.

    MfG

    Michael

  • Moin


    ich denke, hier muss unterschieden werden zwischen der Schaltzeit der Z21 und der Schaltdauer des Decoders.


    Die Schaltzeit der Z21 soll ein gleichzeitiges Umstellen der Weichen einer Fahrstraße verhindern, das Stellen der Weichen einer Fahrstraße wird entzerrt, die Weichen bekommen also nacheinander und nicht gleichzeitig den Stellbefehl (wie beim Vorbild, da laufen die Weichen auch nacheinander um und nicht gleichzeitig). Diese Schaltzeit wirkt nur bei Nutzung einer Fahrstraße und nur bei der Umstellung der Weichen dieser Fahrstraße. Dafür muss also auch eine Fahrstraße programmiert sein und die Schaltzeit regelt nur, wann welche Weiche (bzw. welcher Weichendecoder) den Stellimpuls erhält. Wie lange der Decoder dann nach Eingang des Stellimpulses den Motor ansteuert, wird nicht in der Z21 eingestellt, sondern im Decoder! Du schaltest die Weichen einzeln, also hat die Schaltzeit der Z21 bei Deiner Situation keine Auswirkung, denn die Schaltzeit der Z21 wirkt nur bei programmierten Fahrstraßen.


    Der von Dir verwendete Schaltdecoder hat eine interne Schaltzeit von 4 Sekunden. Das bedeutet, dass der Decoder nach Eingang des Schaltimpulses von der Z21 den entsprechenden Ausgang der Weiche umschaltet und nach 4 Sekunden den Anschluss der Weiche stromlos schaltet. Diese 4 Sekunden können für jeden Ausgang des Weichendecoders individuell eingestellt werden, dazu muss beim Ausgang 1 in die CV 42 der zehnfache Wert der Wunschzeit eingegeben werden (bspw. 20 für 2 Sekunden), für Ausgang 2 ist das die CV 45, für Ausgang 3 die CV 48 etc. Das steht in der Bedienungsanleitung auf Seite 11 unter "Konfiguration Ausgänge". Der Wert "0" stellt die Schaltzeit auf Dauerbetrieb um.


    Also kurz gesagt: Die Schaltzeit der Z21 und die des Decoders sind zwei verschiedene Sachen, die miteinander nichts zu tun haben - bitte nicht miteinander verwechseln!


    Da Deine Antriebe keine 4 Sekunden brauchen, um umzuschalten, würde ich an Deiner Stelle im Decoder die Werte der CV 42, 45, 48 etc. auf einen deutlich kürzeren Wert programmieren, einen Wert, der der Umlaufdauer entspricht, bspw. 15 für 1,5 Sekunden. Warum der Antrieb 5 so merkwürdig reagiert, kann ich aus der Ferne nicht sagen. Schließe den Antrieb 5 doch mal an einen anderen Ausgang und teste ihn da, ob das gleiche Verhalten auftritt.


    Freundlicher Gruß

    EsPe

    Freundlicher Gruß

    EsPe

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!