Z21 und WLAN-Maus - Softwarefehler?

  • Hallo liebe Nuller,


    wir hatten gerade im Verein einen interessanten Effekt:


    Vorweg - wir haben eine WLAN-Maus mit der Lokliste programmiert, und diese dann auf die anderen Mäuse geklont - alle haben jetzt die gleichen Lokstapel.


    Auszug aus dem Lokstapel:
    ..
    ..
    VT98 Addresse 98
    BR01 Addresse 1
    BR24 Addresse 24
    ..
    ..


    Ein Kollege fuhr seinen VT98, und wollte parallel dazu seine 24er in Bewegung setzen,
    er blätterte also im Lokstapel 2 Loks nach unten, und promt setzten sich die 01 und die 24 in Bewegung - denn der Regler stand ja noch bei ca. 30% voraus - der VT98 sollte ja weiterfahren.


    Steht der Regler dagegen auf "0", kann man auch über fahrende Loks drüberblättern, ohne das diese Anhalten.


    Wir haben das dann noch mit mehreren Loks ausprobiert, der Effekt ist immer der gleiche.
    Es scheint so, dass sofort die Lok auf dem Regler aktiv ist, sobald sie in der Liste angewählt ist.
    Man muss anscheinend nicht mehr durch dücken einer Taste oder einer Bewegung am Regler die Ausgewählte Lok auch übernehmen, wie das bei der Lenz-Zentrale z.B. der Fall ist.


    Habt ihr ggf die selben Erfahrungen gemacht?


    Gruß
    Matthias

  • Hallo liebe WLAN Maus Benutzer,


    Habe es auf unserer Anlage mit der vorhandenen Lokliste auch ausprobiert und hatte den selben Effekt,
    passiert aber nur wenn die überblätterten Loks vorher nicht angewählt waren.
    Scheinbar haben diese Loks noch keine Fahr-Information in der Maus hinterlegt und übernehmen den Reglerwert als Initialwert.


    Wenn man alle Loks der Liste mit Fahrstellung Null einmal aufruft (durchblättert) passiert das nicht mehr.


    Hoffe es hilft


    Grüße aus dem Odenwald


    Andreas ;)

    Grüße aus dem Odenwald


    Andreas :)

  • Hallo Nuller,


    habe von Roco eine Antwort erhalten:


    ...
    vielen Dank für Ihre E-Mail-Meldung im Zusammenhang mit der WLAN-MultiMaus 10813. Der von Ihnen
    festgestellte Fehler der sog. "Überempfindlichkeit der Regleränderungs-Abfrage" beim Durchblättern der Lokbibliothek ist mittlerweile bekannt geworden und wurde mit einem 1.Update für die WLAN-MultiMaus beseitigt:
    http://www.z21.eu/Downloads ---> WLAN MULTIMAUS ---> WLAN MULTIMAUS Update V1.01
    ...


    Kann das nur leider hier nicht testen...


    Gruß
    Matthias

  • Hallo Zusammen


    Meine Multimäuse sind schon langen auf dem letzten Firmware Update V1.01. War dann auch wohl der Grund warum ich den Fehler nicht reproduzieren konnte. Ich habe gestern Abend noch mal einen Test durchgezogen. Wenn ich mit "aufgedrehten Regler" durch die Bibliothek blättere und auf einer Lok verharre muss ich erst auf Null zurück und wenn ich dann wieder am Regler drehe reagiert die Lok.
    Die Zentrale ist eine Z21 ist aber wahrscheinlich egal.


    Gruß
    Michael

  • Eintrag wurde durch Datenbank-Reset am WE 26./ 27.09.2020 zentral gelöscht, daher erfolgt noch mal mein händischer Nachtrag.


    Hallo,


    die schwarze Roco WLAN Multimaus hat ein bisher noch ungeklärtes Phänomen integriert.


    Bei Benutzung von 1,2 V Akkus kann es passieren, dass sich die Multimaus auch bei voll geladenen Akkus nicht einschalten lässt. Verwendet man hingegen 1,5 V Batterien, schaltet sie sich ordnungsgemäß ein.


    Das ist deshalb besonders ungünstig, weil Roco explizit die Verwendung von Akkus empfielt bzw. in der Anleitung auch nennt. Somit sollte die Multimaus auch gerade mit 1,2 V Akkus verwendbar sein.


    Roco hat mir das Problem bestätigt und mitgeteilt, dass man an dem Problem bei Roco sucht und forscht. Die Ursache ist derzeit noch unklar. Man vermutet ein Platinen bzw. Softwareproblem.

  • Na ja, ich war mal bei meinem Händler auf einen Digital Infotag von Rocco.

    Dort wurde auch die W-Lan Maus vorgestellt, zu kaufen gab es sie noch nicht.

    Meine Frage nach Akku- Betrieb wurde verneint, die Schaltung wäre auf die höhere Batterie Spannung ausgelegt.

    Das fand ich nicht gut...


    Vielleicht wurde es nach den ersten ausgelieferten ja mal geändert und Du hast noch eine "alte" Maus im Haus?


    Gruß

    Adalbert

  • Hallo zusammen,


    Nun, gut das es da mittlerweile die 1,5V Typen gibt.....


    Schade das solche Sachen immer noch passieren.

    Die Mikrocontroller arbeiten doch problemlos mit 2,85V oder 3,3V.


    Warum man das bei 4 Zellen nicht hinbekommt auch mit einer sehr stark entladenen Zelle so ein Gerät zu betreiben ist mir schleierhaft.


    Selbst wenn der Akku auf 0,9V entladen wäre, liegen 3,6V am Gerät, das reicht allemal um mit einem LowDrop-Regler die 3,3V nahezu verlustfrei zu generieren.


    Wenn ich daran denke, was der ATxmega bei uns in den Geräten leisten muss...... , 2000 Messwerte pro Sek aufnehmen.... und Quasi nebenbei noch Display ansteuert, Tasteneingaben verarbeitet und über Bus sekündlich seine Ergebnisse übermittelt......


    Da ist das Problem mit so nem Handregler nicht nachzuvollziehen....

    Zumal die Anforderungen ja von Begin an bekannt waren.....


    Dafür ist die Z21 App erstaunlich gut gelungen - in meinen Augen...


    Gruß

    Matthias

  • Hallo zusammen,


    da scheinen einige das Produkt nicht genau zu lesen:


    Die erwähnten Lithium-Akkus haben eine Zellspannung von 3,6 V und werden mittels integrierter Schaltung auf 1,5 V heruntergesetzt,


    die von Hubsi aufgeführten Spannungsquellen sind Batterien, keine Akkus, und auch da wird die Spannung mittels integrierter Schaltung auf 1,5 V heruntergesetzt.

    Grüße aus Regensburg


    Heinz ;)

    Edited once, last by Heinz Becke ().

  • Hallo Jörg,


    danke für die Mitteilung der aktuellen Softwarstände. Ich habe nur auf den Beitrag #3 von Matthias reflektiert, in dem der Fehler mit der Spannungserkennung anscheinend behoben sein sollte.


    Wenn dem nicht so ist, dann?

    Grüße aus Regensburg


    Heinz ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!