You are not logged in.

  • "Rainer" started this thread

Posts: 212

Location: Grafschaft

Occupation: Pensionär

  • Send private message

1

Wednesday, January 9th 2019, 10:01pm

ESU LokProgrammer reagiert nicht

Hallo in´s Land,nachdem ich einen neuen Rechner mit Windows 10 Home in Betrieb genommen
habe, funktioniert der Programmer nicht mehr. Als erstes habe ich
daraufhin ein neues Verbindunkskabel mit neuer Treiber-Disk bestellt,
aber das funktioniert auch nur mit Tricks. Der USB Seriell Converter wird
erst dann erkannt, wenn der Programmer stromlos an USB verbunden wird
und danach der Strom zugeschaltet wird. Dann wird ComPort 4 angezeigt
und in den Details das Gerät als "funktioniert einwandfrei"
gekennzeichnet.


Beim Start des Programmers meldet er dann : Zugriff auf den Anschluss wurde verweigert"oder "LokProgrammer nicht gefunden"
Es istdie neueste Software-Version des Programmers installiert

Es lässt sich der ComPort nicht ändern und die Einstellung bzgl. Baudrate etc. sind mir nicht bekannt!




Wer kann helfen?

liebe Grüße aus der Eifel
Rainer

Heizero

Schaffner

(30)

Posts: 260

Location: Heidelberg

Occupation: Rentner

  • Send private message

2

Wednesday, January 9th 2019, 10:49pm

Hallo Rainer,

hast Du schon mal einen Update mit ESU gemacht? Hilft meistens jedenfalls bei mir.

Gruß Günter

  • "Rainer" started this thread

Posts: 212

Location: Grafschaft

Occupation: Pensionär

  • Send private message

3

Wednesday, January 9th 2019, 10:59pm

Hallo Günter,

-na klar!
Ich habe schon deinstalliert, ganz neu aufgespielt, schon eine Vorgängerversion installiert und dann automatisch aktualisieren lassen, die neueste Version des USB-Converters gekauft und installiert ....... und alles geht nicht!
Aber erst, seit ich seit ein paar Tagen das neue Lenovo Ideapad in Betrieb genommen habe! Das war jungfräulich und der Programmer die erste und bislang einzige Software auf dem Gerät !!!!
LG Rainer

jbs

Bahnhofsvorsteher

(189)

Posts: 894

Location: Uelvesbüll

Occupation: Dipl. Ing. (Privatier)

  • Send private message

4

Wednesday, January 9th 2019, 11:01pm

Moin Rainer,

der ESU Programmer macht normalerweise keine Zicken.
So soll es normalerweise aussehen, wobei der COM-Port bei dir unterschiedlich sein kann:
index.php?page=Attachment&attachmentID=40828
Beim Plug and Pray von USB ist die Reihenfolge der Installation nicht immer belanglos.
Probier jetzt mal bitte folgendes in der Reihenfolge:
1. Steckernetzteil vom USB ziehen (oder den Stromstecker am Programmer)
2. USB Stecker ziehen
3. Jetzt dürfte dieses USB-Gerät im Gerätemanager nicht erscheinen

4. Steckernetzteil wieder einstecken
5. USB-Stecker rein
6. Jetzt müßte das USB-Gerät im Gerätemanager zu sehen sein. Wenn nicht, oder die Werte abweichen, mach mal bitte einen Screenshot
7. Im ESU-Programm muss jetzt die USB-Nummer ausgewählt sein, die gerade vergeben wurde.

8. Und es müßte jetzt funktionieren :-) Wenn nicht, hast du wohl den falschen Treiber installiert. Bei mir werkeln die Standard-Windows Treiber für FTDI, nichts von ESU!

Viel Erfolg,
Johann

2 registered users thanked already.

Users who thanked for this post:

minicooper (09.01.2019), Udom (10.01.2019)

  • "Rainer" started this thread

Posts: 212

Location: Grafschaft

Occupation: Pensionär

  • Send private message

5

Thursday, January 10th 2019, 1:03am

Hallo Johann,
bei mir ist alles exakt so wie auf Deinem Screenshot, lediglich COM 4 ist ausgewählt.
Sobald ich aber einen Decoder auslesen oder eine CV auslesen möchte, kommt die Meldung: "Der Zugriff auf den Anschluß wurde verweigert"
Ich habe auch schon andere COM-Ports eingestellt - überall dasgleiche Problem!
LG Rainer

jbs

Bahnhofsvorsteher

(189)

Posts: 894

Location: Uelvesbüll

Occupation: Dipl. Ing. (Privatier)

  • Send private message

6

Thursday, January 10th 2019, 7:53am

Moin moin, Rainer,

hast du einen USB3-Port (die blauen) benutzt? Wenn ja, und sofern dein Notebook noch einen USB2-Anschluss hat, nimm mal bitte den.
Hintergrund: Es gibt Hinweise darauf, dass einige PCs und gerade Notebooks falsche USB-Controller Treiber unter Win10 installiert haben und dadurch die USB3s spinnen.

Welches Modell des Lenovo Ideapad hast du im Einsatz und welche Windows-Version (z.B. 1803) hast du installiert?

Viele Grüße,
Johann

  • "Rainer" started this thread

Posts: 212

Location: Grafschaft

Occupation: Pensionär

  • Send private message

7

Thursday, January 10th 2019, 1:45pm

Hallo Johann,
ich habe die Windows 10 Home, Version 1709, aufgespielt.
Ich habe nur die beiden USB 3.1 Anschlüsse.
LG Rainer

8

Thursday, January 10th 2019, 2:16pm

Moin Rainer.

Falls noch nicht erfolgt, versuche den USB-Treiber zu aktualisieren .
Habe ich mal im ESU Forum gelesen.

LG Guido

jbs

Bahnhofsvorsteher

(189)

Posts: 894

Location: Uelvesbüll

Occupation: Dipl. Ing. (Privatier)

  • Send private message

9

Thursday, January 10th 2019, 2:31pm

Moin,

hmm, ich würde vorsichtig sein, irgendwelche Treiber von Modellbahnherstellern einzuspielen. Alles was hier benutzt wird kommt nicht ursächlich von ESU (außer dem Programmer selbst natürlich).

@Guido,
kannst du einen Link zu der ESU-Aussage angeben?
Vor allem welcher Treiber? Der FTDI oder der vom USB-Controller?
Und kommen die "neuen" Treiber von der ESU-Website oder ist das nur ein Hinweis auf neue Microsoft-Treiber?

@Rainer: Verrätst du uns noch das Modell deines Notebooks? Es kann nämlich gut sein, dass Lenovo Treiber anbietet, die evtl. Mircosoft-Treiber ersetzen müssen. Außerdem ist deine Windows-Version jetzt schon ziemlich angestaubt, was aber noch ok ist, sofern du die Windows-Update aktuell hast. Wenn nicht, vor allen anderen Aktionen: Windows-Update machen! Funktionsupdates auf 1803 oder 1809 müssen nicht zwingend sein. Ich habe 1803. Der Code ist immer Jahr und Monat.
Zusatzfrage: Funktionieren andere Geräte an dem USB-Anschluss, z.B. eine Maus und USB-Stick?

Viele Grüße,
Johann

2 registered users thanked already.

Users who thanked for this post:

Udom (10.01.2019), heizer39 (10.01.2019)

10

Thursday, January 10th 2019, 4:21pm

Moin.

Habe den Eintrag gefunden.

http://www.esu.eu/forum/forenuebersicht/…ert_nicht_mehr/

Es werden beide (FTDI, USB-Controler) erwähnt. Jedenfalls sind Win10 Treiber gemeint.

LG Guido

jbs

Bahnhofsvorsteher

(189)

Posts: 894

Location: Uelvesbüll

Occupation: Dipl. Ing. (Privatier)

  • Send private message

11

Thursday, January 10th 2019, 4:47pm

@Guido,
danke. Was dort beschrieben steht, sieht mir eher nach eher banalen Fehlern aus.

@Rainer,
Ich tippe mal auf einen inkompatiblen USB-3.1-Controller-Treiber. Was sagt denn deine Kiste dazu?
index.php?page=Attachment&attachmentID=40837
Gibt es da irgendwelche Fehlerzeichen? Kannst du mal einen Screenshot davon machen?

Danke und Grüße,
Johann

  • "Rainer" started this thread

Posts: 212

Location: Grafschaft

Occupation: Pensionär

  • Send private message

12

Thursday, January 10th 2019, 6:06pm

Hallo Johann und alle anderen Kollegen hier, die mir hier geholfen haben -

Jetzt mal was erfreuliches:

Nachdem ich zum mindestens 3o. Mal alles getestet habe, habe ich nun
mein "altes" Kabel, welches ich ja für einen der Übeltäter gehalten
hatte, mal angesteckt und siehe da, mit dem neuen Treiber aus 2017 ( von
der beiliegenden CD des neuen Kabels) meldete er sich auf COMPort 3 an
und..... es funktionierte, und zwar wiederholt, auch nach Beenden und
Abziehen des Programmers und Wiedereinstecken.



..... weiss der Teufel, was hier im Busch war!! Ich betreibe nun das alte Kabel und hoffe, dass alles so reproduzierbar ist.



Euch allen noch mal schönen Dank für Eure Hilfe

liebe Grüße aus der Eifel

Rainer

3 registered users thanked already.

Users who thanked for this post:

jbs (10.01.2019), heizer39 (10.01.2019), Udom (10.01.2019)